Payment Gateway VISA transactions
Incident Report for mySMTP
Resolved
This incident has been resolved.
Posted Apr 27, 2021 - 16:11 CEST
Identified
Our Payment Gateway provider Bambora/Epay has problems processing VISA since April 22. Its rooted in the EVRY system.

We have no feedback on when solved. For payment we also accept Mastercard, Mobilepay, PayPal
Posted Apr 27, 2021 - 08:41 CEST
This incident affected: Payment gateway.