Shared mailer down
Incident Report for mySMTP
Resolved
This incident has been resolved.
Posted Jan 07, 2022 - 12:01 CET
Update
We are continuing to work on a fix for this issue.
Posted Jan 07, 2022 - 12:01 CET
Identified
Same problem has resurfaced We are working hard on the fix
Posted Jan 07, 2022 - 11:39 CET
This incident affected: SMTP.dk mySMTP.com uptime.