We do not get any specific information from Apple, but this line:
"We have been able to identify and correct the issue concerned to you so it does not recur, we are unable to provide any additional details. We apologize for the inconvenience. Please let us know if you encounter any further issue.
Best regards, iCloud Mail Team"
mySMTP also apologize for the inconvenience and we strive as always to get fast and smooth mitigation if these blocks happens based on whatever the mailbox provider say and do not say.
Posted Sep 24, 2023 - 19:48 CEST
Identified
We see partial blocks sending emails to Apple domains across the SMTP infrastructure. problem has a high priority to be mitigated
Posted Sep 19, 2023 - 14:50 CEST
This incident affected: Deliverability (icloud.com, me.com, Apple free mails in general).