Major hardware outage at the hosting center
Incident Report for mySMTP
Postmortem

Our shared IP SMTP server platform suffered from a catastrophic hardware failure on the main server also halting the fall over system to work as supposed. Due to this we had several hours downtime as the story of this incident describes. It all started 5 January with same kind of problem, but still not serious in the same way. We made some fixes, monitored - but then the error surfaced again in full force.
The server is only around 5 months old, with top specs on all hardware from SSD x 2 disks, RAM etc. Still the incident happened.
In the end we had to migrate all to a secondary platform, which is time consuming an adds more downtime.
Everything is running again as supposed - and we work on a tripple redundant fall over system. We are aware its a totally unacceptable situation, and we now work hard to add even more uptime guarentee into the platform at the moment.

For those customers with supercritical business applications running on the shared IP platform, we would like to offer you a migration over to our dedicated cloud SMTP server platform. From this you mail out with own IP number, and the VM is an isolated cloud ressource.
If this would be an option please mail us at support@smtp.dk for more details.

We are sorry about these problems and we will do our best to be better on all fronts further on.

Sincerely,

Hans Jul
Founder

Posted Jan 09, 2022 - 10:27 CET

Resolved
This incident has been resolved.
Posted Jan 09, 2022 - 10:09 CET
Update
All systems back online.
Posted Jan 08, 2022 - 15:33 CET
Update
Shared services fully operational.
Posted Jan 07, 2022 - 19:18 CET
Update
Interruptions on Shared services can still occur.
Dedicated server dashboard access is momentarily down.
Posted Jan 07, 2022 - 16:10 CET
Update
Expecting interruptions on the Shared services for the next 45 minutes, due to machine reboots, post-intervention.
Posted Jan 07, 2022 - 15:20 CET
Update
Shared mailing services resumed, speed at ~50% of normal
Posted Jan 07, 2022 - 15:02 CET
Update
We are continuing to work on a fix for this issue.
Posted Jan 07, 2022 - 14:48 CET
Identified
A hosting center hardware failure was identified, the fix is currently in progress.
Posted Jan 07, 2022 - 14:17 CET
This incident affected: SMTP API, Account administration, SMTP.dk mySMTP.com uptime, and Payment gateway.