Delayed delivery smtp.dk and mysmtp.com
Incident Report for mySMTP
Resolved
Small delays to MS365 accounts may appear. This was a problem on Microsofts side and we were not able to get human support to mitigate.
Posted Nov 17, 2020 - 15:07 CET
Update
Delivery delay is only for Microsoft 365 (Office 365) accounts. at the moment All other email providers is normal.
Posted Nov 17, 2020 - 09:32 CET
Identified
Some mails in queue . delivery delayed. Technician is on the case now.
Posted Nov 17, 2020 - 09:13 CET
This incident affected: SMTP.dk mySMTP.com uptime.