Delivery issue to microsoft365 cloud accounts - still present
Incident Report for mySMTP
Resolved
This incident has been resolved.
Posted Nov 20, 2020 - 13:26 CET
Monitoring
We still see 30 min - 1H delay this morning. Still trying to mitigate via Microsoft support - but no feedback yet
Posted Nov 18, 2020 - 10:44 CET
This incident affected: Microsoft 365 email accounts.